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Before You Begin

When you bought this software, we believe you made a
good decision. Why? Because you now have unleashed the
power of integrated Geomet Universal CMM Software to
perform the drudgery of data accumulation and performing
calculations. More importantly, it means that you are now
involved in Statistical Process Control (SPC).

Statistical Process Control (SPC) has become very
important in and necessary in industry today as it can enable
manufacturers to tune their processes and improve their quality
adding a competitive edge over those without SPC.

The first goal of SPC is to determine the nominal,
controlled behavior of a manufacturing process as only then can
you possibly know when it changes and is "out-of-control". Once
you find a point where the behavior does change, you can look
to designate or assign cause of that change. Removing the cause
should put the process back in control. Remember that the key
to improving quality is to control the process that makes the
product.

You should have a sound understanding in SPC before
you start using this software. The manual, by its very nature,
can only be a reference for usage of the software. It cannot be
an acceptable replacement for an instructional course on the
theory and application of SPC. One book on the subject that we
recommend is AT&T's Statistical Quality Control Handbook,
available through the American Society of Quality Control.
Another example is Basic Business Statistics - Concepts and
Application, 7th Edition available through bookstores at most
colleges and universities.
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How to Use This Manual

Please refer the chapter in this manual that contains the information you require.

Chapter 1, "Introducing GeoStat"
Reviews the basic concepts of GeoStat. The standard user interface is described
taking you through the menu hierarchy and icons. How to select features names or
individual data points for processing. Applying filters through the use of fixtures
and dates. 

Chapter 2, "Working with GeoStat"
Describes how to work with GeoStat Header and Measurement Data Records.
Perform database maintenance. Use Limits Tests to provide first warnings when
out-of-control conditions exist. Apply Chart Controls for Standard Deviation
Control Levels, Histogram Cell Groups and Moving Averages.

Chapter 3, "Interaction with Geomet"
Describes how GeoStat processes data directly from Geomet part inspections. The
use of Feature Tagging is demonstrated allowing you to gather only the data
required for study.

Chapter 4, "Charting Capabilities"
Lists the charts available in GeoStat, techniques used to enhance and filter the
data for more precise control and the use of Fixtures, date filtering and sorting.

Chapter 5, "Data - Import/Export"
Describes how you can import data from other applications such as Excel or text
documents. Exporting data in ASCII format can be done from a single record or the
entire GeoStat database. Applying export filters to configure the data to be read by
most other applications.

Appendix A, "Tables"
Provides the common tables used in GeoStat and SPC in general.

Appendix B, "Glossary of Symbols"
This appendix provides descriptions for the most commonly used symbols used in
this Users Guide and SPC in general.

Appendix C, "Glossary of Terms"
This appendix provides descriptions for the most commonly used terms used in this
Users Guide.

Index
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Conventions used in this manual

The following conventional terms, text formatting, and symbols are used
throughout this GeoStat Users Guide.

Convention Meaning

[File->Print] From the File pull-down menu, the Print command is selected.

<F12> The symbols < > represent a selected keystroke from the
keyboard or a left-click button within GeoStat. Example: <F12>
indicates that you should press the F12 (function key). <Accept>
indicates you should left-click on the Accept button on the
dialog shown.
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Taking a Tour of GeoStat
Activating GeoStat
Accessing GeoStat from within Geomet

The GeoStat Menu Structure
Pull-down Menus
File Pull-down Commands
Control Attributes Pull-down Commands
Chart Selection Pull-down Commands
Data Pull-down Commands
GeoStat Options Pull-down Commands
Selection Control Pull-down Commands

Using the GeoStat Data Tree

Applying Filters
Filtering through Date Ranges
Filtering with Fixtures

GeoStat Options
Activate Fixture Filters
Activate the Status Bar
Setting Report Precision
Setting 6 Sigma σ
Taking a Tour of GeoStat
File Locations
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Taking a Tour of GeoStat

GeoStat is an interactive member of the Geomet Universal CMM Software family.
The term interactive implies that GeoStat performs SPC data processing and
reporting as Geomet performs a part inspection. This allows monitoring of the
control process within Geomet immediately after the completion of a part
inspection. GeoStat also performs as a stand alone program.

This chapter will describe the structure and commands available within GeoStat.

Authorizing GeoStat

All Geomet System versions 1.05 or greater offer GeoStat as a released option. If
you have not acquired an Authorization Code to activate GeoStat, please contact
Helmel Engineering Products to purchase one.

When you launch GeoStat from the Windows
Start menu, or from within Geomet, the
security module is tested to determine if your
copy of GeoStat has been authorized. Should
the test show it has not, a warning is displayed
and the program will shut down.

When you receive your Authorization Code,
launch GeoClean and locate [Authorize->Enter
Authorization Code] from the pull-down menus.
Enter the authorization code and GeoStat will
now be ready for use.
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Accessing GeoStat from within Geomet

Accessing GeoStat requires that you first save your current inspection. If this has
been done, press the <F12> function key or from the pull-down menu [Analysis-
>GeoStat] within Geomet. To launch from Windows use:

[Start->All Programs->Helmel Engineering->GeoStat]

GeoStat uses the current part inspection file name as the basis for creating the
matching GeoStat file. For example: if your part inspection is called "Widget.GMT"
your GeoStat file will be called "Widget.GST" and is stored in a separate folder, see
File Locations for default locations.

It should be noted that Geomet and GeoStat will not verify that the file name has
been recycled or renamed and that the GeoStat results no longer correlate with a
new part inspection. For example if you run a part program called "Widget.GMT"
collecting feature attributes in "Widget.GST" you can not rename the main file to
"Widget2.GMT". By doing so you will not collect any further data into Widget.GST
for GeoStat on subsequent inspection runs. GeoStat maintains all feature pointers
inside the original GeoStat "Widget.GST" file.

The GeoStat Display

GeoStat provides access to all features and commands directly from the main
GeoStat display. Selecting a feature to view requires that you left-click on the
feature name. In the example above ID TOP - prod apr 2004 has been selected.
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The GeoStat Pull-Down Menu Structure

File Pull-Down Commands

New
Start a new GeoStat Project

Open
Open an existing GeoStat Project

Close
Close the current GeoStat Project

Append
Append a GeoStat Project to the current open Project

Auto Update - Setup
Provides setup tools to link GeoStat Projects together.

Auto Update - Execute
Executes the links associated with the current
GeoStat Project. This will build a common data set
from all GeoStat projects.

Save
Save the current GeoStat Project.

Save As
Save the current GeoStat Project and assign a new name.

Page Setup
Accesses the underlying printer controls such as orientation, size, margins,
or printer specific capabilities.

Print
Prints the current Chart.
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File Pull-Down Commands - continued

Export Database
Creates or appends an ASCII data file with the entire contents of the filtered
data for all features. The ASCII format is configurable under [GeoStat
Options].

Export Selected Record
Creates or appends an ASCII data file with all filtered data of the currently
selected feature. The ASCII format is configurable under [GeoStat Options].

Import Data
Allows the importing of ASCII data into the currently selected feature.

Sort Records
Performs one of two sort techniques of all data matching the filter criteria.
You can sort on Operator or Date.

Control Attributes Pull-Down Commands

Digital Readout Precision
allows you to choose 2-5 decimal precision on all
values.

Use 6 Sigma
You can choose to apply 3 or 6 sigma.

Draw 3 Control Levels
Draws additional Control levels at ±1-2-3 or ±2-4-6
sigma levels.

Use Limits Tests
When activated, provides auto-prompts when reviewing charts when control
limits have been exceeded.

Print Heavy Lines
Used when printing to high-resolution printers to enhance visibility of lines
being drawn.

Show Graph Bars
Adds shaded bars along the horizontal axis in the graph area.

Batch Printing
Configures the printing tool to print all assigned graphs in one operation.
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Chart Selection Pull-Down Commands

Provides pull-down menu chart selection for the currently
selected feature. The availability of these selections will be
validated against such criteria as number of subgroups, date
ranges, etc.

Data Pull-Down Commands

Enter New GeoStat Header
Manually enters a new Header Record against which
Measurement Data will be entered or imported.

Edit Header Record
Edit all fields in an existing feature header.

Enter New Data Points
Manually enter feature data points into the currently
selected Header Record.

Edit Data Point:
Not available at this time.

Remove Record
Removes the currently selected Header Record and all associated
measurement data.

Remove All Measurements
Removes all measurements from the GeoStat Project.

Database Delete Tools
Activates the database maintenance and delete tools.
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GeoStat Options Pull-Down Commands

Activate Fixture
Activate filtering through the use of fixtures for all
data being evaluated.

Activate Status Bar
Activates the status bar located on the bottom of
GeoStat providing the fly-by help notes and active
clock.

Configure Export Fields
Allows the selection of data used in the exporting of ASCII data files.

Manage SPC Codes db
Builds and maintains the database of Cause and Effect Codes.

File Locations
Used to assign path locations for project storage and Geomet program
locations.

Selection Control Pull-Down Commands

Set Date Ranges
Use this command to establish a range of dates for
processing the data.

Set Moving Average
Sets the number of days that GeoStat will use in the
calculation of Moving Average and Moving Range.

Histogram Cell Count
Sets the cell count the Histogram graph will use when processing the
frequency and grouping of GeoStat data.
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Using the GeoStat Data Tree

The GeoStat Data Tree provides you direct
access to all data by selecting, or
highlighting the feature. To highlight a
feature, left-click with your mouse on the
name located in the Data Tree located right
of the chart. In the example shown here, the
feature named "hotel2" is highlighted and
the corresponding Histogram Chart is
displayed. To change the current chart
assignment, use the pull-down menus:

[Chart Selection->......]

By double clicking on a feature name you
can expand it to show the measurement
data that is stored. In the example, feature ID "Mov Ave" is shown in its expanded
form. To obtain additional information any data point can be expanded to show the
attributes. These include a Cause and Effect Codes, data/time stamp, operator, and
fixtures in use. When a data field has no data stored, the the expanded information
tool will be disabled.
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Applying Filters

GeoStat data can be filtered using two different methods. One method is the use of
dates the second method is through the use of fixtures. These methods can work
together for greater control.

Filtering through Date Ranges

Once you have a Header Record selected you can apply a date range filter. This can
be activated through the Pull-down menu [Selection Control->Set Date Ranges].

When you activate this command, GeoStat will scan the selected record and obtain
the current date range. Enter into the data fields the start and stop dates of the
new range and press the <Enter> key. 

GeoStat will then recalculate the entire database and filter only those data points
that fall within the date range. Note that the date range includes the start and
stop dates.

Filtering with Fixtures

The use of fixtures allows you to group together production that has been
manufactured from the same fixture. We use fixtures as a category that covers
such criteria as machining center ID's, individual fixtures, shift identifiers or any
other usage that may work with your manufacturing environment. The fixture data
is alphanumeric and is case sensitive.

As shown above, up to three fixtures can be used with GeoStat. These fixtures
correspond to what was placed in the inspection header when Geomet performed
the part inspection. You can add or change the fixtures directly inside GeoStat
using the Measurement Data edit tools.
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Filtering with Fixtures - continued

When you elect to use the fixture sorting tool, the fixture
names used are extracted from the database and placed into
the corresponding fixture fields. These are pull-down
selection boxes that you access by left clicking on the down
arrow next to the fixture field as shown in the example. The
listing shown in the pull-down will represent all unique
fixture names used in the feature along with "ANY" and "NONE". To select one of
the entries, highlight the choice with a mouse left-click.

You can set the comparison between the three fixtures with the use of the "Use
AND Comparison" check box. This will apply the following rules when filtering:

When using AND the comparison must match so that Fixture1
AND Fixture2 AND Fixture3 all match before it is added to the process. 

When using OR Comparison the following test is applied where
if Fixture1 OR fixture2 OR fixture3 is true then the record is added to the process.

After you have selected the fixtures and the search comparison, the <Update>
button becomes available. Press the <Update> button and the Data Tree will
update to reflect the new filters.
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File Locations

GeoStat provides a tool to establish links to
various folders. To access this tool use the
pull-down menu:

[GeoStat Options->File Locations]

When GeoStat is installed, default path
designations are provided and only under
specific user needs, they require changing.

GeoStat System
This is the path to the GeoStat.exe program.

Default Path: c:\Program Files\Helmel Engineering\GeoStat\

GeoStat Files
This is the path to the folder that contains the GeoStat database files.

Default Path: c:\My Documents\GeoStat\SPC Database\

GeoStat Export
This path is used when performing an export of GeoStat data in ASCII form.

Default Path: c:\My Documents\GeoStat\ASCII Data\

Choose Configuration
Select the appropriate system configuration. This selection directs the import tools
of GeoStat which path to follow when looking for Geomet or GeoCad generated
ASCII data files. When No CMM Interface is selected, GeoStat acts as a stand
alone application.

Geomet SPC Files
Default Path: c:\My Documents\Geomet 101\SPC Data\

GeoCad SPC Files
Default Path: c:\My Documents\GeoCAD\SPC Data\
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The GeoStat Database
General Description

GeoStat Header Records
GeoStat Header Records
Editing GeoStat Header Records
Control Limit Override
Removing Header Records

GeoStat Data Records
Cause and Effect Codes
Interpreting the Graph and Data Tree
Manually Entering Data Records
Edit Measurement Data Records
Deleting Data Records
Delete all Measurement Data Records

GeoStat Database Delete Record Tools
Delete by Date
Delete by Count

GeoStat Sorting Controls
Sort on Ascending Date
Sort on Operator
Sort on Locator Index

GeoStat Database Appending and Merging
Introduction
AutoLink Setup
AutoLink Execute
Append a Database
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The GeoStat Database - General Description

GeoStat maintains one database for each part program. This database is identified
by the part program name followed by the extension "GST". For example, if your
part program is called "Widget.GMT" your GeoStat database will be called
"Widget.GST".

The default location for these databases can be found at:

C:\My Documents\Geomet 101\GeoStat Data\

You can change the default location from the System Options inside Geomet, refer
to help located inside Geomet.

The GeoStat Database consists of two record types, the Header Record and
Measurement Data Record. The Header Record maintains the feature identification
and the attributes that are being recorded. The Measurement Data Records contain
all measured data collected.
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GeoStat Header Record

The GeoStat Header Record is automatically
created when you tag a attribute of a feature
inside Geomet or manually when selecting from
the GeoStat menu [Data->Enter New GeoStat
Header].

The Header Reord contains the following
data:

Characteristic Name
A Unique name to identify the attribute. For example a feature such as an
XY ID Circle with a number of 4 might have a name "4 X" indicating the X
component of feature number 4.

Nominal Value
This is a basic value for the data to apply upper and lower tolerance against.
The nominal should be the same value as reported in the inspection process.
(+) Plus: This is the Upper Specification Limit (USL).
(-) Minus: This is the Lower Specification Limit (LSL).

Subgroup Size
This value represents the number of measurements of a given group used in
all SPC calculations. In GeoStat the minimum subgroup is 2.

Subgroup Lookback
This is a moving subgroup value that will "lookback" x number of subgroups
when updating charts. For example if the lookback was set at 10, then
GeoStat will only read in from the database 10 subgroups for displaying,
reporting and charting.

Upper Tolerance Limit
This value defaults to the USL. 

Lower Tolerance Limit
This value defaults to the LSL.

Note: You can override the Upper and Lower Tolerance Limits if you want to control
a tighter process.

When a Header has been accepted by pressing the <OK> button or the <Enter>
key, GeoStat will add it to the database and initialize the attached Measurement
Data list.
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Editing GeoStat Header Records

You can edit an existing GeoStat Header Record at any time. To edit, select the
Feature ID in the Data Tree on the right side of GeoStat and from the pull-down
menus select [Data->Edit Header Record]. A second method to start the edit control
is to highlight the Feature ID and press the <Edit> button located below the Data
Tree.

This example shows the current data associated
with "hotel2" which will be displayed allowing
you access to edit any field. After accepting
your changes, GeoStat will recalculate the Data
Tree, reported values and selected charts.

Editing allows you the ability to perform "what-
if" calculations such as increasing the subgroup
size or the look back value on subgroups and
instantly see the change to the reported values.

Note: While you are in GeoStat, any changes you make by editing the Header
Records will not become permanent until you press the <Accept> button. If you
elect not to make a permanent change to the database, press <Cancel>.

Control Limit Override

GeoStat allows you to elect an override when
recalculating the standard deviation, USL and
LSL for the Xbar chart only.

On the GeoStat Header dialog, you can elect
this option by placing a check next to the label;
"Use Manual Control Limits (Xbar)". When
selecting this feature the two entry controls for
USL and LSL become active.

You can now enter a fixed value for use on the
Xbar chart. One condition that this may be
desirable is when you want to monitor your
production against a set of values derived from
a pilot (or test) run. On the report and chart,
the control limits and standard deviation is
marked with "Manual" indicating the calculations were compared against a entered
value.
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Removing Header Records

You can remove an existing GeoStat Header
Record at any time. To remove a Header, select
the Feature ID from the Data Tree on the right
side of GeoStat then from the pull-down menus
select [Data->Remove Record]. When this
command takes place, the header record and all
associated measurement data will be removed.

GeoStat will update the Data Tree showing the
deletion of the record. Note that this will not take effect on the database until you
press <OK> or the <Enter> key. If you press <Cancel> then the changes will not
become part of the database.
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Cause and Effect Codes

Cause and Effect Codes can be assigned to
individual measured data to assign a
standardized message. These messages are
designed by your Quality Control Department
who should be responsible for building the
Cause and Effect Code lookup database.

Cause and Effect Codes are helpful for the
inspector to assign standard messages to a
measurement data point. This help to explain
conditions of the inspection that may cause
undesirable chart behavior.

Maintaining the Cause and Effect db
To build the Cause and Effect db, from the pull-
down menu choose:

[GeoStat Options->Manage SPC Code db]

Add a New Entry
To create a new record, enter a Alpha-numeric
code in “Edit the SPC Database”. In our
example, we show a “B” is entered. The code is
case sensitive allowing for upper and lower case
designation.

To complete the operation, enter a brief
description as to the meaning of the code and
press <Append>.

Delete an Entry
To delete an entry, highlight the entry in the
list and press <Delete>.

When all changes have been completed, press
the <Ok> button to save the data to the Cause
and Effect database.
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Interpreting the Graph and Data Tree

When a Cause and Effect Code has been
assigned to a Measurement Data Record,
it will appear in the Data Tree
highlighted in Bold letters and the
subgroup or data point will be circled in
the graphic area. As shown in this
example, 40.3440 has been expanded to
show that codes A and B are assigned to
it. The 40.3440 is shown in Bold letters
and the subgroup it belongs to is circled. When a measurement data point is
highlighted in the data tree, the graph displays a box with the associated value
shown. When printing this chart, the added information from the Cause and Effect
codes will be printed.

Raw Data Chart
There are special display tools offered
when the selected chart is Raw Data.
When you highlight a measurement data
point in the data tree, the corresponding
node in the graph displays the associated
measurement value and any attached
Cause and Effect Codes.

If you left-click on a node in the graph
area, the corresponding measurement
data point will scroll into view and
highlighted.

Show All Codes
To show all assigned Cause and Effect
Codes in the graph area, double left-click
in any open location within the graph
area, and all Cause and Effect Codes will
appear, see example shown here.
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GeoStat Measurement Data Record

A GeoStat Measurement Data Record consist of actual data
gathered directly from Geomet, entered manually or
imported from applications such as Excel generated ASCII
text file. Data Records are attached to a GeoStat Header
Record and can be viewed in the Data Tree by double
clicking on the feature ID.

In this example we have a GeoStat Feature ID of "3 X" with
the expanded listing of attached data. The first
measurement has been expanded to show the date and time
and fixture usage assigned to the measurement.

Measurements can also have an operator, serial number and
Cause and Effect codes attached to it. GeoStat only displays fields that have data
in the Data Tree. 

GeoStat only displays the measurement data that fall within the date range filter
and subgroup look back value. For example if the subgroup size is five and the look
back is set to ten, then only the last fifty measurements are displayed.
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Manually Entering a Measurement Data Record

You can enter GeoStat Measurement Data
Records against an existing Header. To enter,
select the Feature ID in the data tree and from
the pull-down menus select [Data->Enter New
Data Points]. If the command in the menu is
grayed-out, you have not selected a Feature ID
from the existing data tree.

The Date field will default to the current date
upon opening. The serial number field increments by one with every press of the
<OK> button or <Enter> key.

The SPC Code List offers a lookup function designated by the button, <<?. When
you select this function, the Cause and Effect Code List appears from which you
can choose and existing code, and insert it into the data record. Should you be
required to enter more than one SPC Code, repeat the procedure.

The operator, notes and fixture fields are optional.

Edit Measurement Data Records

Editing an existing measurement data point can be accomplished by highlighting
the measurement in the data tree and calling the command through the pull-down
menu [Data->Edit Data Point] or by selecting the <Edit> button located below the
data tree.
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Deleting Measurement Data Records

For data integrity, GeoStat password protects the deletion of individual data
records. To delete a measurement point, highlight the point in the data tree.
Activate the Edit Data Point Tool through the pull-down menu [Data->Edit Data
Point] or by selecting the <Edit> button located below the data tree.

The measurement point data will be displayed in the Edit Control. Locate the
<Delete> button on the Edit Control. When you are using the delete data point
command for the first time, GeoStat will prompt you for a password. This is to

protect your data from data manipulation or accidental deletions to the
measurement data. Enter the password which has previously been defined. If you
have not previously defined a password, the password you enter here will be saved
for future use. Please record this password and store in a secure place. Additional
Delete commands during this GeoSta session will not prompt for the password.

Delete all Measurement Data Records

All Measurement Data Records can be removed
from the Header Record by highlighting the
Header Record, or any Measurement Data
associated with the Header Record and select
from the pull-down menus [Data->Remove All
Measurements].
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GeoStat Database Delete Record Tools

GeoStat Database files can become very large over
time. When measurement data is volatile, not required
for future use, there are two tools which will
permanently delete measurement data from the
database.

If the data is not volatile, we suggest using the export
tools first to build a historical file of your measurement
data.

To delete measurement data from the database,
there are two options. The first option deletes
all measurement data based on a specified date.
This will remove all measurement data before
and including the specified date. The second
option removes all measurement data by
limiting the size of the database to a specified
allowed number of records.

The Database Delete Tools can be found in the
pull-down menus [Data->Database Delete
Tools].

Delete by Date
Enter a date in mm/dd/yyyy format that will
represent the newest measurement data to
delete permanently from the database. When
accepted <Ok>, all measurement data prior to
the entered date up to and including the
entered date will be deleted.

Delete by Count
With this option, you specify how many
measurement data records to keep in the
database per Header Record.
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GeoStat Sorting Controls

GeoStat offers controls to sort the measurement
data of the selected Header Record by one of
three categories:

Date
Operator
Locator Index

The sort command can be found in the pull-
down menu [File->Sort Records->....].

Sort on Ascending Date
Sorting by the date reorders the measurement
data based on the date field in ascending order.
Measurement Data that has been captured
directly from Geomet is automatically entered
into the GeoStat database using the time and date stamp in ascending order.
However, data that is manually entered or imported does not sort on the date field,
but enters the data in sequential order from the ASCII file. Apply the sort by date
to correct the sequence of entry for the database. To initiate the Date sort, select
the Feature ID from the data tree and then choose from the pull-down menu [File-
>Sort Records->Sort on Date Ascending]. 

Sort on Operator
To group all operators together, select the Feature ID from the data tree and then
choose from the pull-down menu [File->Sort Records->Sort on Operator]. The
resulting action will sort the Header Record by the operator field. This is helpful
when exporting data for further analysis.

Sort on Locator Index
This sort command reorders the Measurement Data within the selected Header
Record in its original order on entry.
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GeoStat Database Appending and Merging

Combining similar GeoStat databases can be helpful when the capturing of
Measurement data has been completed in several CMM or manual entry station
locations. This procedure is known as AutoLink.

AutoLink provides two tools to combine GeoStat database. These are: Setup and
Execute. An example would be the use of two CMMs that capture the same
measurement data from production parts. Each CMM maintains its own GeoStat
database on its own or a shared network drive.

One CMM, or SPC workstation would be designated as the “Master” GeoStat
station. This station would establish the necessary AutoLinks to all associated
GeoStat databases.

AutoLink Setup
The AutoLink Setup Tool assigns the necessary
path designations and Merge characteristics.
The links that are created can be defined to the
entire range of Header Records or to a single,
selected Header Record. To launch the
AutoLink Setup tool, locate in the pull-down
menus [File->Auto Update Setup].

The AutoLink Setup tools appears showing all
Header Record names in a tree structure.

<Add File>
This function allows you to assign one
AutoLink path to an external GeoStat
database. Assigning this link will allow the
AutoLink feature to merge data from the
external GeoStat database. 

To start, press <Add File> and you will
prompted you to navigate with the "Browse
for Folder" dialog. Locate the GeoStat
database you want to automatically merge
measurement values from. After you have
located the file, press <Ok> and the link will be
assigned to ALL GeoStat Header IDs in the
current open database. 

NOTE: If you have designated mapped drive
letters to a remote workstation, it is important to not change those mapping IDs. 
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<Next File>
This function allows you to locate and assign
AutoLinks to other GeoStat databases for
automatic measurement data merging. This
function changes behavior depending on the
current selected item in the display tree.

• No items are selected
• A single GeoStat Header is selected
• One AutoLink path is highlighted

No Items are selected
In this condition, the Next File functions will
update all GeoStat Headers similar to the Add
File function. To start press the <Next File> button and you will prompted you to
navigate with the "Browse for Folder" dialog. Locate the GeoStat database you
want to automatically merge measurement values from. After you have located the
file, press <Ok> and the link will be assigned to ALL GeoStat Header IDs in the
current open database. Next File will add the link to all GeoStat Headers in the
first available open link location. For example: if a link is already assigned to
position number 1, the new link will be recorded in position 2. The same holds true
if position 2 is already assigned then position 3 will be tested. 

A single GeoStat Header is selected
In this condition, the Next File functions will update only the selected GeoStat
Header. To start press the <Next File> button and you will prompted you to
navigate with the "Browse for Folder" dialog. Locate the GeoStat database you
want to automatically merge measurement values from. After you have located the
file, press <Ok> and the link will be assigned to the selected GeoStat Header in the
current open database. 

One AutoLink path is highlighted
When the display tree is expanded you will see the assigned locations for the
AutoLinks plus the option for merging flag. If a single AutoLink is highlighted,
then Next File performs an update only to that selected AutoLink.

An optional method to start the “Browse for Folder” navigation tool begins with
highlighting the AutoLink path and right-click your mouse.
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<Remove File>
This function allows you to remove 1 or all assigned AutoLinks within a selected
GeoStat Header. If the current selection in the display tree is the GeoStat Header
ID, the pressing <Remove File> will delete all assigned AutoLink paths.

If the selected item in the display tree is an AutoLink path, then pressing the
<Remove File> will only remove the selected item.

<Expand All>
Expands all Header Records in the display tree to show the current AutoLinks.

<Collapse All>
Reduces the display tree to show only the Header Records.

<Copy Link> / <Quick Insert>
Not implemented in GeoStat 6.65.

<Clear Paths>
This command will remove all AutoLink assignments in the database.

Append only newest data
When checked, the merge operation will only extract all new data since the last
merge.

<Help>
The Help command provides instant help on all
topics within the AutoLink Setup tool. To use,
press the <Help> button and your mouse will
change into a Question mark cursor. Press any
other button or even the display tree and the
help topic for that selection appears.

Within the help tool, there is a topic tree from which you can select additional help
topics. When you close the Help tool, the mouse will continue to show the Question
Mark cursor until the <Help> button is pressed again.

Auto Update - Execute

This commands executes the merge.
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Append a Database

GeoStat provides a Database Append tool for
combining the Header Records and measurement
data into the current open database.

To launch the Append tool, choose from the pull-
down menus [File->Append]. The Database
Append Options tool will appear which provides
configuration settings on how to handle Header
Records and Measurement Data.

Header Control

Append all data and combine GeoStat Headers
During the Append operation, Header
Records from the remote database that
share a common Header Record name in the
current database will have the measurement
data combined. This is the preferred choice
when combining similar databases from
which one SPC solution will be calculated.

Append all data duplicating common GeoStat Headers
During the Append operation, Header Records from the remote database will not
combine with similar Header Records, but are added to the database as a new
Header Record.

Date Control - Used when combining Headers
When Appending data from a remote database, this section controls how the
measurement data is controlled. Used only when Append all data and combine
GeoStat Headers is selected.

Append only new data based on last date
This option looks at the date measurement records were previously appended at
adds only new measurement data into the current database.

Append all Data
This option appends all measurement data regardless if previously appended.

Proceed with the Append Operation
To proceed, select the options and press the <Ok> button. The file navigation tool
will appear to select the remote database. Once the remote database has been
selected, the append operation will continue automatically.
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Geomet and GeoStat
Creating a New GeoStat Database
Activating Feature Tagging
Selecting Single Attributes
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Creating a New GeoStat Database

As described earlier, GeoStat uses the name of the part program as the base name
for the database. Before you start assigning tags to features to be used in GeoStat
you must save your part program.

Once this has been accomplished, activating Feature Tags inside Geomet will
automatically create the GeoStat database.

Activate Feature Tagging

Within your Geomet Part Program you can activate
the Feature Tagging tool by selecting the feature and
right-click with your mouse to activate the feature
sub-menu see example. Select the menu command
[Feature Tags], which will pass the measured data
from the feature into the Feature Tag Tool. You can
then select the GeoStat button to create a record.

Selecting Single Attributes

The Feature Tagging dialog configures itself for
the current feature. The example here we have
a +Z Point with a actual value of 0.9611. We
circled the GS column showing the GeoStat
button, which has a checkmark placed in the
button. This check indicates that GeoStat
already has an assigned record for this feature.

When you left-click on the button either the
create a new GeoStat Header or edit an
existing GeoStat Header dialog will appear, please review GeoStat Header Records
in chapter 2 for further explanation.

When you have finished editing the GeoStat Header, press <Ok> to save the data
to the GeoStat database.

For complete help on other tagging features inside Geomet, please refer to the on-line
help located inside Geomet.
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Selecting a Chart for Viewing
Using 3 or 6 Sigma σ
Draw Standard Deviation Levels
Using Limit Tests

Histogram Chart
Definition
Setting Cell Count

Moving Average Chart
Definition
Setting Moving Period

Moving Range Chart

Range Chart
Definition

Raw Data Chart
Definition

Xbar Chart

Sigma Chart

Test for Instability

Printing Charts
Printing Single Charts
Printing XBar and Range Combination Chart
Batch Printing of Charts
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Configuring the Charts

Using 3 or 6 Sigma
GeoStat offers you the choice of working with a Standard Deviation of 3 or 6 for all
reporting and charting. The setting of this value is located using the menu [Control
Attributes->Use 6 Sigma (default 3)]. This setting is global to GeoStat in that it
affects all data files.

Draw Standard Deviation Levels
GeoStat provides you with the option to show each Standard Deviation Level
directly on the charts. 

In the examples above, the chart on the right shows the three standard deviation
levels. The setting is global to GeoStat and all available charts and can be found in
the menus under [Control Attributes->Draw 3 Control Levels].

Using Limit Tests

The use of Limit Tests provides a warning when you first view a chart that has an
out-of-control value in it. When GeoStat updates the viewing of a chart it monitors
all calculated data and compares it against the UCL/LCL limits for all charts
accept Raw Data. The Raw Data chart compares the measurements against USL
and LSL.

Limit tests are helpful as an early warning indicator in production environments

where several operators may be asked to review and print charts. To activate this
option choose from the menu [Control Attributes->Use Limit Tests].
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Histogram Chart

The Histogram capability offered by GeoStat is
best described as frequency histogram. The
graph borders extend to include all
measurement data points and are proportional
to the frequencies within the cells. Each bar is
centered on the midpoint of the cells with a
height proportional to the frequencies in their
respective cells.

The chart also draws lines representing the
Nominal, Upper/Lower Specification Limits,
Xbar and Control Limits.

Setting Cell Count
Changing the Histogram Cell Count can be
accomplished by selecting from the menus
[Selection Control->Histogram Cell Count]. A
dialog will appear that defaults to the current
setting. The valid ranges for Histogram are a
minimum of 4 and a maximum of 200.

The cell count is a global setting that effects all
Histogram being displayed and is not
configurable between different GeoStat
Projects.
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Moving Average Chart

A Moving Average Chart is designed for
smoothing a time series and is highly subjective
and dependent of the length of the period used
in constructing the averages.

Understanding the process of moving average
will help you in deciding how to set the period
value, which in Geomet is always considered
days.

To eliminate cyclical fluctuations, the period
should be a value that corresponds to the
estimated length of a cycle. This period can also
be set as a multiple, example; if the cyclical
period is 3 days, an acceptable setting for the
period is 3, 6, 9, etc.

To understand how Moving Average is
calculated, refer to table shown at right.

We have recorded the average production value
of Widgets for consecutive days starting 1/1/99.
The first step is to apply the following formula
to obtain the moving total over the period of 3
days.

X1 + X2 + X3 = MT2 = 6.6+7.2+8.1 = 21.9
X2 + X3 + X4 = MT3 = 7.2+8.1+7.7 = 23.0
X3 + X4 + X5 = MT4 = 8.1+7.7+6.5 = 22.30

Then we compute MA(x) by dividing MT(x) by
the period length L.

21.9 / 3  = 7.30 = MA2
23.0 / 3 = 7.67 = MA3
22.30 / 3 = 7.43 = MA4

The resulting moving average is plotted
centered on the middle value of the period. For
example the moving average for 1/1/99 to 1/3/99
is 7.30 and is plotted against 1/2/99.
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Date Value Moving Total
Moving
Average

1/1/1999 6.6
1/2/1999 7.2 21.90 7.30
1/3/1999 8.1 23.00 7.67
1/4/1999 7.7 22.30 7.43
1/5/1999 6.5 19.40 6.47
1/6/1999 5.2 18.80 6.27
1/7/1999 7.1 19.80 6.60
1/8/1999 7.5 22.30 7.43
1/9/1999 7.7 21.70 7.23

1/10/1999 6.5 21.00 7.00
1/11/1999 6.8 21.40 7.13
1/12/1999 8.1 23.10 7.70
1/13/1999 8.2 24.20 8.07
1/14/1999 7.9 22.00 7.33
1/15/1999 5.9 20.00 6.67
1/16/1999 6.2 18.60 6.20
1/17/1999 6.5 20.00 6.67
1/18/1999 7.3 21.20 7.07
1/19/1999 7.4 21.50 7.17
1/20/1999 6.8 21.20 7.07
1/21/1999 7.0 19.80 6.60
1/22/1999 6.0 18.90 6.30
1/23/1999 5.9 19.40 6.47
1/24/1999 7.5 21.00 7.00
1/25/1999 7.6 22.20 7.40
1/26/1999 7.1



Therefore we can not obtain moving averages
for the first and last day of our date range for a
3-day period (L). The number of days that we
do not plot moving averages for are the first (L-
1)/2 and the last (L-1)/2 days.

When displaying the Moving Average Chart,
there are two X-Y lines being drawn. The black
line represents the daily average and the
moving average is represented in green.

This chart does not employ exponential
smoothing commonly referred as exponential
weighted moving average. 

Setting the Moving Period
Changing the Moving Average Period can be
accomplished by selecting from the menus
[Selection Control->Set Moving Average]. A
dialog will appear that defaults to the current
setting. The valid ranges for Moving Period are
a minimum of 3 and a maximum of 1056 or 3
years.

Besides the minimum and maximum range,
GeoStat also validates that the entered period
length is an odd number.

The period length is a global setting that effects
all Moving Average Charts being displayed and
is not configurable between different GeoStat
Projects.
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Moving Range Chart

The Moving Range chart contains the same
date restraints as the Moving Average. Each
node in the chart, represents the range within
the subgroup.

In the displayed graph, the solid blue line
represents the Moving Range Average. The
Total Range is represented numerically in the
report.

To set the Moving Period, please refer to
Setting the Moving Period described in the
Moving Average section on the previous page.
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Range Chart

The Range Chart (R) monitors variability of the
process by charting the difference of the largest
and smallest within a subgroup of
measurements. The range charts work together
with the Xbar Chart and should be reviewed
prior to developing the Xbar chart. A typical R
chart must be set with a subgroup of 2 or more
but should not be greater than 10. The
sampling size or subgroup look back should be
20 or more, if possible, but not less than 10. R
charts will enable you to determine whether
the variability of a process is in control or
whether shifts are occurring over time. If the
process range is in control, then it can be used to develop control limits for the
average.

Control limit ranges for R charts are calculated using the following equation:

UCL = Rbar + SL * Rbar * (d3 / d2)
LCL = Rbar - SL * Rbar * (d3 / d2)

where:

Rbar = average of all the observed ranges.
SL = GeoStat Control Limit Setting 3 or 6.
d3 = Table of factors, refer to Appendix A.
d2 = Table of factors, refer to Appendix A.
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Raw Data Chart

The Raw Data Chart charts all measurement
observations exclusive of their subgroups, but
limited to the subgroup look back value. For
example if the subgroup size is 5 and the look
back is 10 there will be 50 plotted
measurements.

From these measurements GeoStat will
compute the Standard Deviation, Xbar and
Total Range. The chart will reflect these values
and be scaled between the LSL and USL or, if
required the largest extent of measurements.

This chart is useful as an aid in observing the overall pattern of your
manufacturing process. Additionally it provides a visual reference when conditions
such as out-of-control or out-of-specification exist.

The Raw Data Chart interacts with Cause and Effect Codes to produce a printed
graph showing the location and code assignment attached to the individual
measurement data nodes, see Cause and Effect Codes.
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XBar Chart

The Xbar chart monitors variability of the
process by charting the average of the
measurements within a subgroup. This chart is
used after the R chart in the control process.

The combination of the R and Xbar charts offer
the most sensitive control in identifying and
tracing causes to your process. The data plotted
for each subgroup is derived from the following
equation:

Xbar = (X1 + X2 + X3 +….Xn) / n

where:

n = subgroup size
X1..Xn = measurements within each subgroup

The Estimate of averages of the subgroup averages and Control limit ranges for
Xbar charts are calculated using the following equation:

Xbarbar = (Xbar1 + Xbar2 + Xbar3 +…Xbark) / k
UCL = Xbarbar + SL * ( Rbar / ( d2√n ) )
LCL = Xbarbar - SL * ( Rbar / ( d2√n ) )

where:

Xbarbar = average of all subgroup averages.
Xbar(n) = sample mean for subgroup n.
Rbar = average of all the observed ranges.
k = number of subgroups.
SL = GeoStat Control Limit Setting 3 or 6.
d2 = Table of factors, refer to Appendix A.

In addition, the process capability index or CpK is reported here, see Glossary of
Terms for definition.
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Sigma Chart

The Sigma Chart when used with the R chart
provides monitoring of the variation of a
process over time. Unlike the Xbar chart which
works with the estimated mean of subgroup,
the Sigma chart monitors the variation within
the subgroup. The plotted observations are the
Standard Deviation σ for each subgroup.

The average sigma is derived from the
estimated mean of all calculated subgroup σ
values. The standard deviation for all
subgroups are then calculated from the
subgroup σ values and the control limits, 3 or 6,
is then reported to complete the chart.

NOTE: The Sigma Chart has been removed from GeoStat!
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Tests for Instability

GeoStat provide 4 standard tests when viewing
the control charts Xbar and Sigma. These tests
are performed to provide the operator an early
warning that an "unnatural" pattern is
forming.

The 4 tests that are performed include:

Test 1
Any point outside of the control limits.

Test 2
Two out of three successive points fall in Zone C or beyond.

Test 3
Four out of five successive points fall in Zone B or beyond.

Test 4
any 8 consecutive data points on one side of the centerline.

GeoStat will display warning statements in the lower message area of the display.
If more than one test fails, the message will indicate all warnings, as shown in the
example above.
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Printing Charts

Printing on demand is accomplished through
the pull-down menu command [File->Print], or
by using the <Q-Print> button located under
the data tree.

There are three options to printing available
when selecting through the pull-down menus.
These options are:

Print Current Chart
Print XBar and Range
Batch Printing of Charts

Print Current Chart
This command will print the current chart. 

Print XBar and Range
This command creates a dual report providing
the Charts and Results for the XBar and Range
Charts on a single form, see example.

Batch Printing of Charts
Due to the high number of chart that can be
printed, GeoStat offers a Batch Print utility
which is configured per Header Record, and
acts upon the Batch Print command.

Before Batch Printing is available, each Header
Record must be configured through the pull-
down menu:

[Control Attributes->Batch Printing]

This setup tool configures the Header Record
for Batch Printing by assigning one or more
charts for printing. Place a check next to the
chart type and press <Ok> to same the setup,
or press <Apply to All> to assign the print
setup to all Header Records. 

To perform a Batch Print select from the pull-
down menus:

[File->Batch Print...]
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Importing Data
Data File Structure
Importing a Data File
Example from Excel
Importing a Data File in Subgroup Order

Exporting Data
Configuring Export Fields
Exporting the Entire Database
Exporting One Feature
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Importing Data

In GeoStat you can attach measurement data
against an established GeoStat Header through
the use of the Import command [File->Import
Data->...].

This command opens an ASCII data file that
has columns of data that are comma or space
delimited. Most applications from spreadsheets,
word processors and other measurement
devices can write ASCII data files. 

Importing of data starts by highlighting a
Header Record in the data view tree. This will
be the recipient of the imported data.

Import Data File Structure (non-subgroup)
GeoStat works with several data structure
formats allowing flexibility as to the data fields
that are required. The structures of the data
fields are:

Actual, Date, Time, Serial Number, Operator, Fixture1, Fixture2, Fixture3

where:

Actual is any valid number.

Date can be any of the following examples:
1/25/1999 01/25/1999
January 25 1999 Jan 25 1999
25 January 1999 25 Jan 1999

It should be noted that we require full year, 1999 not 99.

Time can be any of the following examples:
09:30:00 (hours:minutes:seconds)
09:30 (hours:minutes)
21:30:00

The time format should conform to the 24-hour format where 21:00 is
equal to 9:00 p.m.

Serial Number is any alphanumeric string.

Operator is any alphanumeric string.

Fixtures are any alphanumeric strings.
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Importing a Data File (non-subgroup)
Before you begin the import process, you should
select which Feature ID, or GeoStat Header
Record to attach the incoming data too. After
you have your feature chosen select the data
file from the Open File Dialog located at [File-
>Import Tool->Import Data]. Locate your ASCII
text file and press <Open>. GeoStat will extract
the measurements from the data structure as
described above.

GeoStat extracts the data starting with the measurement value in the left column.
It is not required to have data in all fields, as the examples below will illustrate.

GeoStat evaluates the first data line to determine if it contains column labels. If it
determines that the first letter is not a number, then it will skip that line and
proceed with the next. This should be noted when creating labels for columns. A
label "Circle 2" will be evaluated as a label where "2 Circle" will extract the "2" as a
measurement value.

Example using Excel Spreadsheet Software
One way data can be created is through the use of the Microsoft Excel spreadsheet.
In the example below we created a file which we will then enter the measurement
data.

In the example above we have data in different fields allowing us the ability to skip
data when it is not required.  

When you have entered all your data proceed to save your work. Choose from the
menu command [File->Save As] a save dialog
will appear. Set the format in the pull-down
"Save as type:" "CSV (Comma delimited)(*.csv)".
Provide a file name and the location to store the data.

Actual CVS Data File
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Meas. Value Date Time
Serial

Number
Operator Fixture 1 Fixture 2 Fixture 3

10.251 10/19/2003 John
10.2605 10/19/2003 8:00 John H1A
10.2598 10/19/2003 H2B
10.2594 10/19/2003 8:05:00 00102 John

Meas. Value,Date,Time,Serial Number,Operator,Fixture 1,Fixture 2,Fixture 3
10.251,10/19/2003,,,John,,,
10.2605,10/19/2003,8:00,,John,,,H1A
10.2598,10/19/2003,,,,H2B,,
10.2594,10/19/2003,8:05:00,00102,John,,,



Import Data File Structure (subgroup)
GeoStat imports ASCII data files that are created in a Row / Column format where
each Row is a subgroup. The structures of the data fields are:

Actual1, Actual2, Actual3, Actual4,........Actualn

In this example, we have a data file that contains 5 measurements per subgroup
and there is a total of 3 subgroups.

Importing a Data File (subgroup)
Before you begin the import process, you should select which Feature ID, or
GeoStat Header Record to attach the incoming data too. After you have your
feature chosen select the data file from the Open File Dialog located at [File-
>Import Tool->Subgroup Import]. Locate your ASCII text file and press <Open>.
GeoStat will extract the measurements from the data structure as described above.

GeoStat extracts the data starting with the first measurement value in the left
column and continues looking for measurement values until the end of the line is
reached.
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10.2536 10.2585 10.2542 10.2556 10.2538
10.2528 10.2535 10.2541 10.2555 10.2562
10.2542 10.2538 10.2562 10.2523 10.2511



Exporting Data

GeoStat provides an export capability to save your
measurement data in the ASCII text form for use
with other applications. These text files are comma
delimited and the format for the data is controlled
by the command Configure Export Fields.

Configure Export Fields
To configure the ASCII export characteristics for
all data being exported select from the menu;
[GeoStat Options->Configure Export Fields]. You
can define the following fields for the export
format:

1. Only Actuals
2. Feature ID
3. Date / Time
4. Operator
5. Serial Number
6. Fixtures
7. SPC Codes
8. Export by Subgroups

Export by Attributes
By selecting fields 2, 3, 4, 5, 6 or 7 or any combination of, you are configuring the
ASCII export to place in comma delimited format the respective data. The columns
are constructed as follows:

Feat ID, Actual, Date, Time, Serial Number, Operator, Fixture1, Fixture2, Fixture3, Code1, Code2, Code3

An example of a record being exported with all field tags selected will look like:

3 X, 1.1230, 25/10/1999 00:00:00, 1, John, f1, f2, f3, A, B, C

An example that has only Feature ID selected would look like:

3 X, 1.1230

An example that has only SPC Codes selected would look like:

1.1230, A, B1, D
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Export by Subgroups
When you select "Export By Subgroups" all other options will become grayed-out
and unavailable. This method is used to allow grouping of data for use in
applications such as Excel spreadsheets. When you select this option, your output
will look like:

9.9805, 49.9805, -10.0195, -0.0195, 9.9805, ….
25.5000, 25.0000, 25.0000, 24.5000, 24.5000, ….

Each line across will contain one full subgroup as defined in the Feature Header.
This will allow for better assignment of calculations where each row is a subgroup.

Export Using Only Actuals
When you select "Only Actuals" all other options will become grayed-out and
unavailable. This method exports all actual in a single column. When you select
this option, your output will look like:

9.9805
49.9805
-10.0195
-0.0195
9.9805
25.5000
25.0000
25.0000
24.5000
24.5000
….

Exporting the Entire Database
To Export all measurement data select from the menu [File->Export Database].
This command will export all data within the database in an ASCII text field using
the format as specified in Configure Export Fields.

If you specify an existing file, GeoStat will prompt you whether to over-write or
replace the file.

The data file created will contain groups of data where each group is the
measurement data from a single Header Record. Each group is separated by a
blank line.
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Control Chart Factors
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Tables

Observations in Sample d2 d3
2 1.128 0.853
3 1.693 0.888
4 2.059 0.88
5 2.326 0.864
6 2.534 0.848
7 2.704 0.833
8 2.847 0.82
9 2.97 0.808

10 3.078 0.797
11 3.173 0.787
12 3.258 0.778
13 3.336 0.77
14 3.407 0.763
15 3.472 0.756
16 3.532 0.75
17 3.588 0.744
18 3.64 0.739
19 3.689 0.733
20 3.735 0.729
21 3.778 0.724
22 3.819 0.72
23 3.858 0.716
24 3.895 0.712
25 3.931 0.708
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Symbol Description Note
σ Sigma Standard Deviation

LCL Lower Control Limit Lowest Control Point for acceptable values
LSL Lower Specification Limit Nominal  Lower Tolerance

R Range Total Range example: Range Chart
Rbar R-Bar Average of all observed values
SL Sigma Limit Specifies 3 or 6 Sigma Level

UCL Upper Control Limit Highest Control Point for acceptable values
USL Upper Specification Limit Nominal + Upper Tolerance
Xbar XBar Average of each observed subgroups

Xbarbar XBar Bar Average of all Xbar values

Glossary of Symbols



*.csv a comma delimited file format used in Microsoft Excel to save
data into a ASCII formatted file.

*.GST the extension used for native file formats within GeoStat.

*.GMT the extension used for native file formats within Geomet.

ASCII American Standard Code for Information Interchange. The file
format used by GeoStat for import and export of measurement
results for use by other applications.

Attributes a single characteristic of a measured feature. Example: the X
location of a XY Circle.

Cell Count the number of cells, or bars, GeoStat will use in the creation of
a Histogram.

Centerline either the Xbar of control and range charts or the nominal or
raw data charts.

Control Levels when activated, GeoStat draw control levels at 1-2 standard
deviation on a 3 sigma control or 2-4 standard deviation levels
when configured for 6 sigma. These lines represent Zones A, B
and C.

CpK Process capability index. The reported value is the lesser of
(USL - Mean) / (SL * σ) and (Mean - LSL) / (SL * σ).

Date Range a user defined range of dates that GeoStat will use when
building the measurement files to be used in SPC.

Double clicking the process of applying two fast-button presses from the mouse
using the left button. Used in selection and expanding
processes.

Feature ID the visible name of a feature shown the data display of the
GeoStat window.
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Feature Tagging the process of assigning a feature within Geomet to be exported
to GeoStat.

Fixtures user defined fields in Geomet and GeoStat that allow
segregating of measurement results to reflect location of
manufacture, fixtures assigned too, etc.

Header the record identifier for a single attribute that GeoStat will
capture all common measurements against. The Header
maintains the tolerance values, subgroup sizes, and subgroup
lookback and is shown in GeoStat as the Feature ID.

Histogram shown as a bar graph whose heights of the bars represent the
frequency of distribution of all measurements. The bars, or cell
widths, are inclusive of the measurement range.

LCL Lower Control Limit. The calculated limits of control based on -
3 or - 6 standard deviation.

Limit Test provides a pop-up warning box when viewing a control charts
that has point(s) outside the control limits or when exceeding
the specification limits on a Raw Data chart.

LSL Lower Specification Limit (Nominal - Lower Tolerance).

Moving Average smoothing calculation of a set of observations over a time
period.

Moving Period the number of days used as the smoothing factor for Moving
Average and Moving Range charts.

Nominal the basic value from the print for the measured feature.

Print Heavy Lines doubles the weight of printed lines when using high-resolution
printers.

R (Range) the difference of the largest and smallest within a subgroup of
measurements.

Raw Data provides a chart that represents all measurement values with
regard to the LSL - Nominal - USL levels.

Report Precision the number of places to the right of the decimal place for all
charts and calculated results.

Subgroup Lookback a user defined value that will represent how many
subgroups GeoStat will use in calculating values for all charts.
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Test 1 a test to review the current chart for any data points that
exceed the control limits. Test 1 applies to the Xbar and Sigma
charts only.

Test 2 a test to review the current chart for any 2 data points from 3
consecutive data points that are in Zone C or beyond. Test 2
applies to the Xbar and Sigma charts only.

Test 3 a test to review the current chart for any 4 data points from 5
consecutive data points that are in Zone B or beyond. Test 3
applies to the Xbar and Sigma charts only.

Test 4 a test to review the current chart for any 8 consecutive data
points on the same side of the Xbar line. Test 4 applies to the
Xbar and Sigma charts only.

UCL Upper Control Limit. The calculated limits of control based on +
3 or + 6 standard deviation.

Unnatural a pattern of data points that fail to balance themselves around
the centerline of the control chart. GeoStat uses Test1, 2, 3 and
4 for identify these.

USL Upper Specification Limit (Nominal + Upper Tolerance).

Zone A,B,C these zones represent three equally spaced levels between the
centerline to either ± 3 or 6 standard deviations. They are also
referred as "one sigma zone" or "two sigma zone", etc. Zone A is
equal to Xbar ± 1 standard deviation when configured for 3
sigma.
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*.csv 5 - 3, C - 1
*.GMT C - 1
*.GST 2 - 2, C - 1
.GMT 1 - 3, 2 - 2
<F12> 1 - 3
6 Sigma 1 - 1, 1 - 5, 4 - 1, 4 - 2, B - 1, C - 1

A

Accessing GeoStat 1 - 3
Append a Database 2 - 16

Date Control - Used when combining Headers
2 - 16

Append all Data 2 - 16
Append only new data based on last date 2
- 16

Header Control 2 - 16
Append all data and combine GeoStat
Headers 2 - 16
Append all data duplicating common
GeoStat Headers 2 - 16

Proceed with the Append Operation 2 - 16
Appending and Merging 2 - 13

AutoLink Setup 2 - 1, 2 - 13, 2 - 15
<Add File> 2 - 13
<Clear Paths> 2 - 15
<Collapse All> 2 - 15
<Copy Link> 2 - 15
<Expand All> 2 - 15
<Help> 2 - 15
<Next File> 2 - 14
<Quick Insert> 2 - 15
<Remove File> 2 - 15
Append only newest data 2 - 15
File->Auto Update Setup 2 - 13

Appendix A - Tables A - 1
ASCII iii, 1 - 5, 1 - 7, 2 - 8, 2 - 12, 5 - 2, 5 - 3, 5 - 4,
5 - 5, 5 - 6, C - 1
Attributes C - 1
Authorization Code 1 - 2
Authorizing GeoStat 1 - 2
AutoLink Database Tools 2 - 13

AutoLink Execute 2 - 15
AutoLink Setup 2 - 13

B

Batch Printing of Charts 4 - 12
Control Attributes->Batch Printing 4 - 12
File->Batch Print... 4 - 12
setup tool 4 - 12

C

Cause and Effect Codes 1 - 7, 1 - 8, 2 - 1, 2 - 6, 2 -
7, 4 - 8

Add a New Entry 2 - 6
Delete an Entry 2 - 6

Interpreting the Graph and Data Tree 2 - 7
Maintaining the Cause and Effect db 2 - 6
Raw Data Chart 2 - 7
Show All Codes 2 - 7

Cell Count 1 - 7, 4 - 1, 4 - 3, C - 1
Centerline 4 - 11, C - 1, C - 3
Chart Selection Pull-Down Commands 1 - 6
Charting Capabilities 4 - 1
Combining GeoStat Databases 2 - 13
Comma delimited 5 - 3
Configure Export Fields 5 - 5, 5 - 6
Configuring the Charts 4 - 2

Draw Standard Deviation Levels 4 - 2
Using 3 or 6 Sigma 4 - 2
Using Limit Tests 4 - 2

Control Attributes Pull-Down Commands 1 - 5
Batch Printing 1 - 5
Digital Readout Precision 1 - 5
Draw 3 Control Levels 1 - 5
Print Heavy Lines 1 - 5
Show Graph Bars 1 - 5
Use 6 Sigma 1 - 5
Use Limits Tests 1 - 5

Control Chart Factors A - 1
Control Levels C - 1
Control Limit Override 2 - 4
Conventions iv
CpK 4 - 9, C - 1
Creating a New GeoStat Database 3 - 2

D

d2 4 - 7, 4 - 9, A - 1
d3 4 - 7, A - 1
Data Import / Export 5 - 1
Data Pull-Down Commands 1 - 6

Database Delete Tools 1 - 6
Edit Data Point 1 - 6
Edit Header Record 1 - 6
Enter New Data Points 1 - 6
Enter New GeoStat Header 1 - 6
Remove All Measurements 1 - 6
Remove Record 1 - 6

Data Tree 1 - 1, 1 - 8, 2 - 1, 2 - 4, 2 - 7, 2 - 9, 2 - 10,
4 - 12
Database Delete Record Tools 2 - 11

Data->Database Delete Tools 2 - 11
Delete by Count 2 - 11
Delete by Date 2 - 11

Date Range 1 - 9, 2 - 8, 4 - 5, C - 1
Delete Measurement Data Records 2 - 10

Data->Edit Data Point 2 - 10
Password Protection 2 - 10

Double clicking C - 1

E
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Edit Measurement Data Records 2 - 9
Data->Edit Data Point 2 - 9

Editing GeoStat Header Records 2 - 4
Enter New GeoStat Header 2 - 3

Characteristic Name 2 - 3
Lower Tolerance Limit 2 - 3
Nominal Value 2 - 3
Subgroup Lookback 2 - 3
Subgroup Size 2 - 3
Upper Tolerance Limit 2 - 3

Excel iii, 2 - 8, 5 - 1, 5 - 3, 5 - 6, C - 1
Export By Subgroups 5 - 6
Exporting Data 5 - 5

Configure Export Fields 5 - 5
Export by Attributes 5 - 5
Export by Subgroups 5 - 6
Export Using Only Actuals 5 - 6
Exporting the Entire Database 5 - 6

F

Feature ID C - 1
Feature Tagging C - 2
Feature Tags 3 - 2

Activate Feature Tagging 3 - 2
Selecting Single Attributes 3 - 2

File Locations 1 - 11
Choose Configuration 1 - 11
GeoCad SPC Files 1 - 11
Geomet SPC Files 1 - 11
GeoStat Export 1 - 11
GeoStat Files 1 - 11
GeoStat Options->File Locations 1 - 11
GeoStat System 1 - 11

file name 1 - 3
File Pull-Down Commands 1 - 4

Append 1 - 4
Auto Update - Execute 1 - 4, 2 - 15
Auto Update - Setup 1 - 4
Close 1 - 4
Export Database 1 - 5
Export Selected Record 1 - 5
Import Data 1 - 5
New 1 - 4
Open 1 - 4
Page Setup 1 - 4
Print 1 - 4
Save 1 - 4
Save As 1 - 4
Sort Records 1 - 5

Filters 1 - 9
Date Ranges 1 - 9
Filtering with Fixtures 1 - 9

AND Comparison 1 - 10
OR Comparison 1 - 10

Fixtures 1 - 7, C - 2

G

GeoClean 1 - 2
Enter Authorization Code 1 - 2

Geomet i, 1 - 2, 1 - 3, 3 - 1, 3 - 2
GeoStat Data Tree 1 - 8
GeoStat Database 2 - 2, 2 - 11, 2 - 13, 3 - 2
GeoStat Options Pull-Down Commands 1 - 7

Activate Fixture 1 - 7
Activate Status Bar 1 - 7
Configure Export Fields 1 - 7
File Locations 1 - 7
Manage SPC Codes db 1 - 7

Glossary of Terms C - 1

H

Header C - 2
Header Record 1 - 6, 2 - 2, 2 - 3, 2 - 4, 2 - 5, 2 - 8, 2
- 10, 2 - 11, 2 - 12, 2 - 13, 2 - 16, 4 - 12, 5 - 2, 5 - 3,
5 - 4, 5 - 6
Helmel Engineering Products i, 1 - 2
Histogram C - 2
Histogram Cell Count 4 - 3
Histogram Chart 1 - 8, 4 - 1, 4 - 3

I

Importing Data 5 - 2
Example using Excel Spreadsheet Software 5 -
3
File->Import Data->... 5 - 2
Import Data File Structure (non-subgroup) 5 -
2

File->Import Tool->Import Data 5 - 3
Import Data File Structure (subgroup) 5 - 4
Importing a Data File (non-subgroup) 5 - 3
Importing a Data File (subgroup) 5 - 4

Interaction with Geomet 3 - 1
Introducing GeoStat 1 - 1

L

LCL 4 - 2, 4 - 7, 4 - 9, B - 1, C - 2
Limit Test 4 - 2, C - 2
Locator Index 2 - 12
Lower Control Limit B - 1, C - 2
Lower Specification Limit 2 - 3, B - 1, C - 2
LSL 2 - 3, 2 - 4, 4 - 2, 4 - 8, B - 1, C - 1, C - 2

M

Manage SPC Code db 2 - 6
Manual Control Limits 2 - 4
Manually Entering a Measurement Data Record 2
- 9

Data->Enter New Data Points 2 - 9
SPC Code List 2 - 9

Measurement Data Record 2 - 2, 2 - 7, 2 - 8
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Cause and Effect Code 2 - 9
Delete all Measurement Data Records 2 - 10
Deleting Measurement Data Records 2 - 10
Edit Measurement Data Records 2 - 9
Manually Entering 2 - 9
serial number 2 - 9

Menu Structure 1 - 4
minimum subgroup 2 - 3
Moving Average 1 - 7, 4 - 1, 4 - 4, 4 - 5, 4 - 6, C - 2

Setting the Moving Period 4 - 5
Moving Average Chart 4 - 4
Moving Period 4 - 1, 4 - 5, 4 - 6, C - 2
Moving Range 1 - 7, 4 - 1, 4 - 6, C - 2
Moving Range Chart 4 - 6

N

Nominal C - 2

O

out-of-control ii, iii, 4 - 2, 4 - 8
out-of-specification 4 - 8
Override Control Limits 2 - 4

P

Password Protect Data 2 - 10
Print Heavy Lines C - 2
Printing Charts 4 - 1, 4 - 12

<Q-Print> 4 - 12
Batch Printing of Charts 4 - 12
Print CurrentChart 4 - 12
Print X-Bar and Range 4 - 12

R

R 4 - 7, 4 - 9, 4 - 10, B - 1, C - 2
Range Chart 4 - 1, 4 - 7
Raw Data C - 2
Raw Data Chart 2 - 7, 4 - 1, 4 - 2, 4 - 8
Rbar 4 - 7, 4 - 9, B - 1
References ii

AT&T Statistical Quality Control Handbook ii
Basic Business Statistics - Concepts and
Application, 7th Edition ii

Removing Header Records 2 - 5
Data->Remove Record 2 - 5

Report Precision 1 - 1, C - 2

S

s 1 - 1, 4 - 1, 4 - 10, B - 1, C - 1
security module 1 - 2
Selection Control Pull-Down Commands 1 - 7

Histogram Cell Count 1 - 7
Set Date Ranges 1 - 7
Set Moving Average 1 - 7

Set Date Ranges 1 - 9

Sigma 1 - 1, 1 - 5, 4 - 1, 4 - 2, 4 - 10, 4 - 11, B - 1, C
- 1, C - 3
Sigma Limit B - 1
SL 4 - 7, 4 - 9, B - 1, C - 1
Sorting Controls 2 - 12

File->Sort Records->.... 2 - 12
Sort on Ascending Date 2 - 12

File->Sort Records->Sort on Date
Ascending 2 - 12

Sort on Locator Index 2 - 12
Sort on Operator 2 - 12

File->Sort Records->Sort on Operator 2 - 12
Standard Deviation iii, 2 - 4, 4 - 1, 4 - 2, 4 - 8, 4 -
10, B - 1, C - 1, C - 2, C - 3
Statistical Process Control ii
Statistics Symbols used in GeoStat B - 1
status bar 1 - 7
Subgroup Import 5 - 4
Subgroup Lookback C - 2

T

Tables A - 1
Test for Instability 4 - 1
Tests for Instability 4 - 11

Test 1 4 - 11, C - 3
Test 2 4 - 11, C - 3
Test 3 4 - 11, C - 3
Test 4 4 - 11, C - 3

U

UCL 4 - 2, 4 - 7, 4 - 9, B - 1, C - 3
Unnatural 4 - 11, C - 3
Upper Control Limit B - 1, C - 3
Upper Specification Limit 2 - 3, B - 1, C - 3
USL 2 - 3, 2 - 4, 4 - 2, 4 - 8, B - 1, C - 1, C - 2, C - 3

W

Working with GeoStat 2 - 1
www.geomet-cmm-software.com i
www.helmel.com i

X

XBar 2 - 4, 4 - 1, 4 - 3, 4 - 7, 4 - 8, 4 - 9, 4 - 10, 4 -
11, 4 - 12, B - 1, C - 1, C - 3
XBar Chart 4 - 9

Tests for Instability 4 - 11
Xbarbar 4 - 9, B - 1

Z

Zone A,B,C C - 3
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